Bug Error (Chat)

#1
Code:
#0 src/XF/Mvc/Entity/Entity.php(575): XF\Mvc\Entity\Entity->_castValueToType(NULL, 'username', 5, Array)
#1 src/XF/Mvc/Entity/Entity.php(505): XF\Mvc\Entity\Entity->set('username', NULL)
#2 src/XF/Service/Thread/Replier.php(102): XF\Mvc\Entity\Entity->__set('username', NULL)
#3 src/XF/Service/Thread/Replier.php(40): XF\Service\Thread\Replier->setPostDefaults()
#4 src/XF/Container.php(274): XF\Service\Thread\Replier->__construct(Object(XF\Pub\App), Object(EWR\Porta\Entity\Thread))
#5 src/XF/App.php(1362): XF\Container->createObject('ForoAgency\\Shou...', Array)
#6 src/XF/Container.php(228): XF\App->XF\{closure}('ForoAgency\\Shou...', Array, Object(XF\Container))
#7 src/XF/App.php(2511): XF\Container->create('service', 'XF:Thread\\Repli...', Array)
#8 src/addons/ForoAgency/Shoutbox/Repository/Messages.php(72): XF\App->service('XF:Thread\\Repli...', Object(EWR\Porta\Entity\Thread))
#9 src/addons/ForoAgency/Shoutbox/Cron/Archive.php(12): ForoAgency\Shoutbox\Repository\Messages->archiveMessages()
#10 [internal function]: ForoAgency\Shoutbox\Cron\Archive::archiveMessages(Object(XF\Entity\CronEntry))
#11 src/XF/Job/Cron.php(35): call_user_func(Array, Object(XF\Entity\CronEntry))
#12 src/XF/Job/Manager.php(241): XF\Job\Cron->run(G)
#13 src/XF/Job/Manager.php(187): XF\Job\Manager->runJobInternal(Array, G)
#14 src/XF/Job/Manager.php(76): XF\Job\Manager->runJobEntry(Array, G)
#15 job.php(14): XF\Job\Manager->runQueue(false, 8)
#16 {main}

-------------

Previous InvalidArgumentException: Attempted to convert NULL to string/binary - src/XF/Mvc/Entity/ValueFormatter.php:130
#0 src/XF/Mvc/Entity/Entity.php(693): XF\Mvc\Entity\ValueFormatter->castValueToType(NULL, 5, Array)
#1 src/XF/Mvc/Entity/Entity.php(575): XF\Mvc\Entity\Entity->_castValueToType(NULL, 'username', 5, Array)
#2 src/XF/Mvc/Entity/Entity.php(505): XF\Mvc\Entity\Entity->set('username', NULL)
#3 src/XF/Service/Thread/Replier.php(102): XF\Mvc\Entity\Entity->__set('username', NULL)
#4 src/XF/Service/Thread/Replier.php(40): XF\Service\Thread\Replier->setPostDefaults()
#5 src/XF/Container.php(274): XF\Service\Thread\Replier->__construct(Object(XF\Pub\App), Object(EWR\Porta\Entity\Thread))
#6 src/XF/App.php(1362): XF\Container->createObject('ForoAgency\\Shou...', Array)
#7 src/XF/Container.php(228): XF\App->XF\{closure}('ForoAgency\\Shou...', Array, Object(XF\Container))
#8 src/XF/App.php(2511): XF\Container->create('service', 'XF:Thread\\Repli...', Array)
#9 src/addons/ForoAgency/Shoutbox/Repository/Messages.php(72): XF\App->service('XF:Thread\\Repli...', Object(EWR\Porta\Entity\Thread))
#10 src/addons/ForoAgency/Shoutbox/Cron/Archive.php(12): ForoAgency\Shoutbox\Repository\Messages->archiveMessages()
#11 [internal function]: ForoAgency\Shoutbox\Cron\Archive::archiveMessages(Object(XF\Entity\CronEntry))
#12 src/XF/Job/Cron.php(35): call_user_func(Array, Object(XF\Entity\CronEntry))
#13 src/XF/Job/Manager.php(241): XF\Job\Cron->run(G)
#14 src/XF/Job/Manager.php(187): XF\Job\Manager->runJobInternal(Array, G)
#15 src/XF/Job/Manager.php(76): XF\Job\Manager->runJobEntry(Array, G)
#16 job.php(14): XF\Job\Manager->runQueue(false, 8)
#17 {main}
Stato richiesta
array(4) {
  ["url"] => string(8) "/job.php"
  ["referrer"] => string(40) "https://rload.eu/forums/suggerimenti.66/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Walky

Admin - Developer
Staff member
#2
Hello,

This is probably because of the archiving feature. Please disable it until the next update to avoid these errors :)

Regards
 

gox11

New member
#3
  • ErrorException: Failed to write files for ForoAgency/Shoutbox action, including src/addons/ForoAgency/Shoutbox/addon.json, src/addons/ForoAgency/Shoutbox/hashes.json, src/addons/ForoAgency/Shoutbox/Repository/Messages.php
  • src/XF/Error.php:75
#0 src/XF.php(187): XF\Error->logError('Failed to write...', false)
#1 src/XF/Job/AddOnInstallBatch.php(153): XF::logError('Failed to write...')
#2 src/XF/Job/AddOnInstallBatch.php(74): XF\Job\AddOnInstallBatch->stepInit(Object(XF\Timer))
#3 src/XF/Job/Manager.php(253): XF\Job\AddOnInstallBatch->run(G)
#4 src/XF/Job/Manager.php(195): XF\Job\Manager->runJobInternal(Array, G)
#5 src/XF/Job/Manager.php(111): XF\Job\Manager->runJobEntry(Array, G)
#6 src/XF/Admin/Controller/Tools.php(120): XF\Job\Manager->runByIds(Array, 8)
#7 src/XF/Mvc/Dispatcher.php(321): XF\Admin\Controller\Tools->actionRunJob(Object(XF\Mvc\ParameterBag))
#8 src/XF/Mvc/Dispatcher.php(248): XF\Mvc\Dispatcher->dispatchClass('XF:Tools', 'RunJob', Object(XF\Mvc\RouteMatch), Object(NF\TeamSpeak\XF\Admin\Controller\Tools), NULL)
#9 src/XF/Mvc/Dispatcher.php(100): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(NF\TeamSpeak\XF\Admin\Controller\Tools), NULL)
#10 src/XF/Mvc/Dispatcher.php(50): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#11 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#12 src/XF.php(390): XF\App->run()
#13 admin.php(13): XF::runApp('XF\\Admin\\App')
#14 {main}

Version 1.1.4

@Walky
 

Walky

Admin - Developer
Staff member
#4
  • ErrorException: Failed to write files for ForoAgency/Shoutbox action, including src/addons/ForoAgency/Shoutbox/addon.json, src/addons/ForoAgency/Shoutbox/hashes.json, src/addons/ForoAgency/Shoutbox/Repository/Messages.php
  • src/XF/Error.php:75
#0 src/XF.php(187): XF\Error->logError('Failed to write...', false)
#1 src/XF/Job/AddOnInstallBatch.php(153): XF::logError('Failed to write...')
#2 src/XF/Job/AddOnInstallBatch.php(74): XF\Job\AddOnInstallBatch->stepInit(Object(XF\Timer))
#3 src/XF/Job/Manager.php(253): XF\Job\AddOnInstallBatch->run(G)
#4 src/XF/Job/Manager.php(195): XF\Job\Manager->runJobInternal(Array, G)
#5 src/XF/Job/Manager.php(111): XF\Job\Manager->runJobEntry(Array, G)
#6 src/XF/Admin/Controller/Tools.php(120): XF\Job\Manager->runByIds(Array, 8)
#7 src/XF/Mvc/Dispatcher.php(321): XF\Admin\Controller\Tools->actionRunJob(Object(XF\Mvc\ParameterBag))
#8 src/XF/Mvc/Dispatcher.php(248): XF\Mvc\Dispatcher->dispatchClass('XF:Tools', 'RunJob', Object(XF\Mvc\RouteMatch), Object(NF\TeamSpeak\XF\Admin\Controller\Tools), NULL)
#9 src/XF/Mvc/Dispatcher.php(100): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(NF\TeamSpeak\XF\Admin\Controller\Tools), NULL)
#10 src/XF/Mvc/Dispatcher.php(50): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#11 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#12 src/XF.php(390): XF\App->run()
#13 admin.php(13): XF::runApp('XF\\Admin\\App')
#14 {main}

Version 1.1.4

@Walky
Hello,

Please provide more details, when it happens ?
By the way, this doesn't seem to be related to the Shoutbox but more likely to TeamSpeak (line 8 and 9)

Regards,
Walky
 
Mobile app for XenForo 2 by Appify
Top